Skip to main content

History: Setting Up An Application - Visual Studio

Preview of version: 3

Microsoft Visual C++ 2008

Important:

Make sure you have the current patchs and service packs for Visual Studio 2008.

Note: You can use the Ogre Application Wizard to set up a Visual Studio project. The project can be empty or include the files used by the Starting Tutorials. This set of instructions is for those people who wish to build a project from scratch or who wish to understand all the things that the Ogre Appwizard accomplishes.

Prerequisites

  • Visual Studio 2008 must be installed.
  • The Ogre SDK version 1.7 or greater must be installed.
    • Installing the Ogre SDK
    • Building Ogre from source with CMake


These instructions make the assumption that the Ogre SDK has been installed on your system. This means you downloaded the Ogre SDK or built and installed the Ogre SDK from source. It is possible to build the Ogre SDK from source and not go through the process of installation but the location of files will be different. There should be enough information in this article to figure out how to configure your project from that intermediate build point.

The steps involved are:

  1. Create a new project: File | New | Project
  2. Under project types 'Visual C++' then under Templates select 'Win32 Project'.
  3. Enter a name for your project. I suggest OgreTemplate so that it's purpose is obvious. These files can be be copied over to a new directory when creating a new Ogre project thus avoiding this long process. Change the location to point to a work directory. It should not be in either the SDK directory or in the source files for Ogre.

VC2008_Window_NewProject

  1. Click the OK button and the Win32 Application Wizard will be displayed.

VC2008 Win32 AppWizard Page 1.jpg

  1. Press the Next Button.
  2. Select 'Windows Application' and 'Empty project' when prompted for the type of project to create.

VC2008 Win32 AppWizard Page 2.jpg

  1. Press the Finish button

At this point, some of the steps become less intuitive. Good organization dictates that we at least keep our header (.h) files separate from our source(.cpp) files. There are several ways to create sub-directories under our project directory. I will stick to doing everything in Visual Studio. At this point, the Solution Explorer window should be displayed, probably docked on the left side of the Visual Studio Window. If it is not, select the menu View | Solution Explorer.
VC2008 Solution Explorer Default.jpg

  1. If you hover over the second button in the Solution Explorer's toolbar, you will see that it says "Show all files" It should not currently be toggled so you should click on it to toggle it. Now you will see this display of Solution Explorer.
 Plugin Image
File not found.
  1. Select the menu Project | New Folder and type "source" in the editable area that is displayed in the Solution Explorer. This will create a sub-directory under the project directory called "source".
  2. Click on the project OgreTemplate in the Solution Explorer window. This will ensure that the next sub-directory gets created under the project directory and not under the source directory you just created. Select the menu Project | New Folder and type "include" in the editable area that is displayed in the Solution Explorer. This will create a sub-directory under the project directory called "include".
  3. Again, click on the project OgreTemplate in the Solution Explorer window. Select the menu Project | New Folder and type "scripts" in the editable area that is displayed in the Solution Explorer. This will create a sub-directory under the project directory called "scripts".
 Plugin Image
File not found.


  1. Create a new source file by selecting 'Project -> Add New Item...'. Make sure the file is in the work directory. This step must be performed before editing project properties (otherwise the 'C/C++' page will be unavailable).
  2. Save the project.


If you named your project "Testproject" and selected a location like C:\Work, and checked the box called "Create directory for solution", with a solution name of "Testsolution", then the directory structure will be: C:\Work\Testsolution\Testproject. If you do not create a directory for the solution, the structure will simply be: C:\Work\Testproject.

To clarify where the DLL files should be, an easy way is to copy the \bin folder (containing \debug and \release) and the \media folder from the OGRE installation directory to your Testproject folder (note: in this case you might be copying DLLs that won't be needed, but it's the hassle-free way). If you follow the convention presented above and you created folders for the header, scripts and source files, you have the following folders under \Testproject (excluding subfolders): 'bin', 'include', 'media', 'testsolution', 'scripts', and 'src'. However, if you don't want to copy them while running your Testproject from Visual Studio just add the path to OGRE's DLL files to the %PATH% global environment variable like this:

Copy to clipboard
Debugging : Environment = PATH=%PATH%;%OGRE_HOME%\bin\debug

and for the release version

Copy to clipboard
Debugging : Environment = PATH=%PATH%;%OGRE_HOME%\bin\release

This will not modify the %PATH% environment variable permanently, just for the given run, so its safer. You could modify it globally for all windows applications like this:

Copy to clipboard
My Computer -> Properties -> Advanced -> Environment Variables -> System Variables -> Path += ;%OGRE_HOME%\bin\debug

or

Copy to clipboard
My Computer -> Properties -> Advanced -> Environment Variables -> System Variables -> Path += ;%OGRE_HOME%\bin\release

but this could lead to confusion if working with different Ogre versions and is not recommended.

If you follow the next few steps carefully, your project should compile without errors.

Configure your project with the following settings. All of these are for the Debug configuration. To set up the Release configuration just change the directories from '\Debug\' to '\Release\'. Select "project properties" and under "configuration properties" add the following:

Copy to clipboard
Debugging : Command = $(OutDir)\$(ProjectName).exe Debugging : Working Directory = $(OutDir) C/C++ : Preprocessor : Preprocessor Definitions += _STLP_DEBUG (only in Debug mode, not needed for .Net 2003 and 2005) C/C++ : Code Generation : Use runtime library = Multithreaded Debug DLL (Multithreaded DLL in Release) Linker : General : Output File = ..\bin\Debug\[appname].exe Linker : Input : Additional Dependencies += OgreMain_d.lib OIS_d.lib (OgreMain.lib OIS.lib in Release)

If you also use CEGUI, you need to tell Visual Studio to link the libs by doing this:

Copy to clipboard
Linker : Input : Additional Dependencies += CEGUIBase_d.lib OgreGUIRenderer_d.lib (CEGUIBase.lib OgreGUIRenderer.lib in Release)

And, for those using the SDK:

Copy to clipboard
C/C++ : General : Additional Include Directories = ..\include;$(OGRE_HOME)\include;$(OGRE_HOME)\samples\include Linker : General : Additional Library Directories = $(OGRE_HOME)\lib

Or, for those using the source release:

Copy to clipboard
C/C++ : General : Additional Include Directories = ..\include;$(OGRE_SRC)\OgreMain\include;$(OGRE_SRC)\Samples\Common\Include Linker : General : Additional Library Directories = $(OGRE_SRC)\OgreMain\Lib\Debug
Additional hints on getting your application to run from within the IDE:<br \>

Visual Studio Debugging Settings

History

Information Version
Wed 22 of Apr, 2020 09:56 GMT-0000 paroj 141
Mon 24 of Aug, 2015 04:11 GMT-0000 petrocket Fixed link to Ogre app wizard 140
Sun 31 of May, 2015 11:26 GMT-0000 spacegaier 139
Tue 31 of Mar, 2015 06:24 GMT-0000 kabbotta 138
Fri 17 of Oct, 2014 13:29 GMT-0000 spacegaier 137
Fri 19 of Sep, 2014 08:50 GMT-0000 gerymate 136
Fri 19 of Sep, 2014 08:49 GMT-0000 gerymate 135
Sat 21 of Sep, 2013 21:04 GMT-0000 Flateno Page updated for alternative Ogre 1.9 134
Sat 21 of Sep, 2013 20:57 GMT-0000 Flateno 133
Sat 21 of Sep, 2013 20:55 GMT-0000 Flateno 132
Sat 21 of Sep, 2013 20:42 GMT-0000 Flateno Update for Ogre 1.9 131
Sat 21 of Sep, 2013 20:27 GMT-0000 Flateno 130
Sat 21 of Sep, 2013 20:27 GMT-0000 Flateno 129
Sat 21 of Sep, 2013 19:49 GMT-0000 Flateno 128
Sat 21 of Sep, 2013 19:48 GMT-0000 Flateno 127
Sat 21 of Sep, 2013 19:48 GMT-0000 Flateno 126
Sat 21 of Sep, 2013 19:38 GMT-0000 Flateno 125
Sat 21 of Sep, 2013 19:35 GMT-0000 Flateno 124
Sat 21 of Sep, 2013 19:30 GMT-0000 Flateno 123
Fri 08 of Jun, 2012 03:47 GMT-0000 jacmoe 122
Fri 25 of May, 2012 23:55 GMT-0000 jacmoe Boost version is no longer part of directory name 121
Mon 26 of Mar, 2012 07:42 GMT-0000 Nikitron 120
Mon 26 of Mar, 2012 07:41 GMT-0000 Nikitron Fixed links to new version of the Boost from the Ogre. 119
Fri 14 of Oct, 2011 08:25 GMT-0000 Tytanis Added ogre.cfg because I believe it should be here as well! 118
Sun 31 of Jul, 2011 23:41 GMT-0000 jacmoe 117